The FrogPad

Roastmaster Support => Support => Topic started by: cinderblock on February 05, 2017, 05:13:35 AM

Title: Probe Unlinked - I need help
Post by: cinderblock on February 05, 2017, 05:13:35 AM
Hi, I'm a bit daunted by the task of reinitiating myself with Roastmaster and the probes.

I originally purchased the K-type thermocouples and the Roastmaster app about five years ago, and I remember having issues starting it up even then so this is not new territory for me by any means. It's been a while, so I don't know how I got the darn thing to work, but here I am again. I cannot figure out how to link the probes.

I wish there was a Get Started - Link the Thermocouples to the computer + iPhone page at the top of the website, as I've always considered it the biggest hurdle, alongside purchasing the right parts. But once again, I find myself scouring the website for bread crumbs.

Anyway, I have two problems. First problem - the Phidget Control panel will not open. Yes, there's a small icon on the bottom right corner of my lame Windows desktop, but I cannot physically get a window to appear. Apparently, the icon says it's running, but I don't know if I'm supposed to open the window and input something for the darn probes to link up. I remember the last time, the Control Panel window did open, although once you set it up, you never had to touch it again. You just had to make sure it was open to run Roastmaster. Maybe I downloaded the wrong Phidget for my PC. I'm on Windows and I downloaded the latest version suggested on your website, because I also downloaded the most recent version of Roastmaster...

Secondly, I don't know if I'm properly set up. Yes, I've hooked up the Phidget to the laptop via USB, but how does the iPhone come into play? Do I need to turn on Blue Tooth? How does the Phone detect whether or not the probes are linked? Does it detect it by WiFi? I get the feeling I'm missing a big step here. Maybe there's a cable that I lost that's supposed to link to the iPhone??? So far, the laptop is linked to the Phiget by USb, but that's it...

Thirdly, maybe the Phidget is broken... I don't know how you'd ever know. Gah... I have a headache.
Title: Re: Probe Unlinked - I need help
Post by: cinderblock on February 05, 2017, 05:27:00 AM
Was navigating the website once more and I realized the Phidget download suggestion page might be outdated... because the latest suggestion is for a version of 7.0... but then on the front page, it announces the latest version of Roastmaster (which I assume is the version I downloaded) is 8.0.

Is there a new Phidget version I need to download?
Title: Re: Probe Unlinked - I need help
Post by: cinderblock on February 05, 2017, 05:48:19 AM
So I noticed the version 8.0 was released on 12/1/14, so I downloaded the Phidget update predating that...

Now I could get the window of the Control Panel to open by double clicking, so that's resolved.

But now I have  another problem.

Question, what serial do I enter into the Roastmaster app? There's a serial when I open the Phidget Control Panel, and there are individual serial stickers affixed to each Thermocouple. I assume it's the serial displayed in the CP, because as soon as I entered it for one of the Probes, my Roastmaster keeps freezing and I have to shut it down. I do not however know how to get the Roastmaster to run anymore... I guess this means the Phone is picking up something. I just don't understand why it's freezing up the app...
Title: Re: Probe Unlinked - I need help
Post by: cinderblock on February 05, 2017, 06:00:18 AM
Alright, so I'm really confused at this point.

I have individual serial stickers on each K probe. I'm assuming these are not the serials that need to be entered into the Roastmaster app, because when I do, nothing happens. They remain unlinked.

There's another serial when I open the Phidget control panel... but there's only one. And when I enter it for one of the probes, the Roastmaster app immediately freezes. So I'm getting the feeling this serial is allowing the signal to be picked up, but for whatever reason, instead of the app saying the probes are linked, it just freezes and I need to restart it...

The other thing is, I tried inputting the same serial on both probes, and the app would not allow it, citing a conflict. So then does that mean one of the probes I have is dead? Because the Phidget CP only shows one Serial under Device... but then it indicates the device as Phidget Temperature Sensor 4-Input... so I'm really confused.

Title: Re: Probe Unlinked - I need help
Post by: cinderblock on February 05, 2017, 06:04:14 AM
I tried installing the most current Phidget version, assuming maybe there was a Roastmaster update since the 12/01/14 version and thus I needed a newer Phidget version...

But alas the probes are still unlinked...
Title: Re: Probe Unlinked - I need help
Post by: cinderblock on February 05, 2017, 06:23:32 AM
When I double click Phidget Temperature Sensor 4-Input, I get an errror saying that Thermocouple 3 reported a potential of 83.3 mv which is above the maximum 77.4.

Also, when I click on Probe 1, I get a temperature readout on the Control Panel, so I guess the probe is working. But the other ones... 0, 2, 3 all give me Err.
Title: Re: Probe Unlinked - I need help
Post by: cinderblock on February 05, 2017, 11:12:56 AM
Alright, at last, I found a thread that addressed the same issue I had.

I tried changing the port on the Control Panel to 5050. Didn't work.

However, the firewall rule trick did the job.

The only other thing was rewiring one of the thermocouple probles, because one of them had severed from the Phidget. I forgot how tricky that part was, and remember being extremely careful with the handling of the phidget. After five years of moving all over the place, I forgot how precarious the wiring was... anyway, I'm glad I finally got everything set up. Can't wait to start roasting tomorrow.
Title: Re: Probe Unlinked - I need help
Post by: Danny Hall on February 07, 2017, 04:26:26 PM
Hi cinderblock

Was a little preoccupied getting the latest version of Roastmaster released yesterday - getting back into the routine today.

Glad you were able to get things up and running. Using an SBC for a host is more forgiving with regard to a Firewall. Windows tends to be pretty aggressive with its filtering–certain routers as well (Comcast in the US).

For future googles...The Setting Up Phidgets ( page has links for purchasing hardware. Just search "Phidgets" on the home page in case that permalink changes.

Regarding the version chart on that page...Phidgets USED to be very finicky about the software API version - the build running on your probe host had to be identical to the build running in Roastmaster. That is no longer the case in practice. Technically, they say it still should, but I haven’t seen that problem occur in a few years. 9 times out of 10, the problem is Windows firewall.

A couple of weeks ago I aggregated of list of the tech support requests I’ve received for Phidgets, and prioritized them by the number of incidents. I'll try to post that list soon on the site as a "Troubleshooting" page. Phidgets can be a bit daunting to get up and running - and that type of documentation is currently lacking.

Any other questions, let me know.