The FrogPad
 
A forum to get help or talk about Roastmaster…or anything else coffee.

Temperature Readout Intermittent  (Read 1547 times)

biowilly

  • (7 Posts)
  • *
  • Karma: 0
    • View Profile
I am getting an intermittent temperature readout whether I am roasting or not.  I have tried resetting the SBC as well as my iPad and this will provide a temporary fix. Has anyone else experienced this problem and if so, is there a fix?

tburres

  • (16 Posts)
  • *
  • Karma: 0
    • View Profile
I have had problems over the past 3-4 weeks as well.  Last weekend I was unable to get my probes linked at all - I could connect to the SBC from a PC and see it connected to my wifi, also able to verify that the temperature sensors were working, but could not link to Roastmaster.

Danny Hall

  • (378 Posts)
  • *****
  • Karma: 3
    • View Profile
    • Rainfrog
Thanks for letting me know.

About 6 weeks ago, I incorporated the latest Phidgets driver build into the beta version of RM. So, all of my devices are running a newer Phidgets WITHIN Roastmaster than the driver version that is currently running in iTunes version of RM. (This is a separate driver embedded inside RM, and different from the Host driver you have installed on either an SBC or laptop).

I have not personally seen any changes, but if a problem has arisen in one of Apple’s many 10.0.x updates, it may be masked on my end, if Phidgets has identified a problem in iOS and fixed it in their latest driver.

My own experience…Phidgets performance in the last couple of major iOS builds has deteriorated. In my own roasting, I’ll get a disconnect about once per roasting session - usually in the first roast. It will recover on its own, and usually remain intact from then on out for subsequent roasts. (This is what has led me to develop the RDP protocol that I’ll be releasing in the coming version of RM).

Occasionally (more rarely), my roasting iPad will fail to connect to the Phidgets SBC at all. In these cases, other apps that use Ethernet are also failing. Even Safari won’t work in the instances until a restart is performed.

Can you both please provide some more details about how frequently this occurs? Also, when it happens, can you load a webpage in Safari on the iOS device?

biowilly: it sounds like a restart fixes things for you. How long until it recurs?

tburres: Have you tried restarting the iPad?

The coming version of RM is in beta. You are both welcome to participate in the beta, whereby you’d have access to the NEW Phidgets driver. Please send me an email support@rainfroginc.com if you want to participate. We could set this up on Monday.

Danny

tburres

  • (16 Posts)
  • *
  • Karma: 0
    • View Profile
Thanks Danny - Email on the way with some more details on my experience.  Yes I tried restarting the iPad and yes I can still access other apps from the ipad - safari, facebook etc.  Thanks a ton - this is the one area of RM I still have trouble with from time to time so it will be great to get it sorted out!