The FrogPad
 
A forum to get help or talk about Roastmaster…or anything else coffee.

Facebook error  (Read 2001 times)

Micahgallant

  • (1 Posts)
  • *
  • Karma: 0
    • View Profile
Anyone else getting an error after trying to post to fb or twitter?

Danny Hall

  • (375 Posts)
  • *****
  • Karma: 3
    • View Profile
    • Rainfrog
Hi Micah

Try turning your Facebook and Twitter settings off, then back on again in the device Preferences.

I rewrote Facebook in this update to function solely on the iOS SDK, instead of the Facebook SDK. I ran into what may be the same problem with Facebook during development, but could never find an issue in the code. Every time I installed the latest development build on my device, Facebook would refuse to function because of permission problems. iOS was seeing it as a new app, and not honoring the permissions I'd previously granted on that device to Roastmaster.  Toggling the setting in preferences fixed it, and it was fine after that. I eventually just chalked it up to an iOS bug, or one of the slew of quirky things that happen with permissions when running a development version, thinking it wouldn't happen in a release version.

Hopefully this will fix your issues. If it doesn't or you ever notice it again, please let me know.

Thanks
Danny