The FrogPad
 
A forum to get help or talk about Roastmaster…or anything else coffee.

Setting up data logging  (Read 6784 times)

trk_koa

  • (2 Posts)
  • *
  • Karma: 0
    • View Profile
OK. So I have my phidgets thermocouple showing readings on my PC laptop. I have configured and started the web service in the phidgets control panel.

Bonjour shows it is running. Laptop and iPad are on the same wireless network.

In RoastMaster, I create a probe, enter the serial number and port 0 (I only bought the 1 port PTS).

The probe says "unlinked". Any idea what step I missed?

Laptop is running Windows 7. Is there anything I need to configure in the laptop security or anything?

I am really looking forward to getting this up and running.
Thanks! Nancy

trk_koa

  • (2 Posts)
  • *
  • Karma: 0
    • View Profile
Aha. I think I have figured it out. There was a mismatch in the webservice prototcol with the Phidgets latest version. I was able to find the links on their site to the older version and have installed that and I now am getting data from the stand alone thermocouple. Whoo hoo.

Now I just need to attach the thermocouple and my roaster and we will be cooking.

Nancy

Danny Hall

  • (375 Posts)
  • *****
  • Karma: 3
    • View Profile
    • Rainfrog
Hi Nancy

Glad you're up and running! I'll let the guys at Phidgets know about this. I used a previous version throughout development, and never saw this error - obviously it shouldn't be happening.

Let me know if you have any other questions.

Danny

Coffeeric

  • (3 Posts)
  • *
  • Karma: 0
    • View Profile
Hi Nancy,

I just encountered the same problem like what you had.  However, I am using Mac OSX.  Just wonder where do you find an older version of the driver? 

Thanks,
Eric


Aha. I think I have figured it out. There was a mismatch in the webservice prototcol with the Phidgets latest version. I was able to find the links on their site to the older version and have installed that and I now am getting data from the stand alone thermocouple. Whoo hoo.

Now I just need to attach the thermocouple and my roaster and we will be cooking.

Nancy

Coffeeric

  • (3 Posts)
  • *
  • Karma: 0
    • View Profile
Just got a quick response from Danny.  He gave me a link to download an older version from Phidgets website.  Looking forward to tomorrow roasting.

e.

Hi Nancy,

I just encountered the same problem like what you had.  However, I am using Mac OSX.  Just wonder where do you find an older version of the driver? 

Thanks,
Eric


Aha. I think I have figured it out. There was a mismatch in the webservice prototcol with the Phidgets latest version. I was able to find the links on their site to the older version and have installed that and I now am getting data from the stand alone thermocouple. Whoo hoo.

Now I just need to attach the thermocouple and my roaster and we will be cooking.

Nancy

Danny Hall

  • (375 Posts)
  • *****
  • Karma: 3
    • View Profile
    • Rainfrog
I Spoke to Phidgets - the error is 100% accurate. You must use the same version of the Phidget software as the internal API that Roastmaster is using inside the app. I had thought there was forward-compatibility, but this is not the case.

I will be maintaining a chart of driver compatibility in the new Setting Up Data Logging post in the documentation on the main site.

Sorry for your troubles and thanks for letting me know about this.

Danny